What’s Vulnerable › Vulnerabilities
CVE-2024-14044: Open5GS Diameter Rx pcrf-rx-path.c pcrf_rx_aar_cb buffer overflow
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-10-01
- Weakness: CWE-119
Description
A vulnerability was identified in Open5GS up to 2.7.1. This issue affects the function pcrf_rx_aar_cb of the file src/pcrf/pcrf-rx-path.c of the component Diameter Rx Handler. The manipulation of the argument num_of_media_component/num_of_sub leads to buffer overflow. The attack can be initiated remotely. The exploit is publicly available and might be used. Upgrading to version 2.7.2 is capable of addressing this issue. The identifier of the patch is 87b4e4535c77ded627cdb6f4e4e2e3ea761f40b7. It is recommended to upgrade the affected component.
Affected products
- Open5GS: 2.7.0, 2.7.1
References
- https://github.com/open5gs/open5gs/
- https://github.com/open5gs/open5gs/commit/87b4e4535c77ded627cdb6f4e4e2e3ea761f40b7
- https://github.com/open5gs/open5gs/files/15051247/capture.pcap.gz
- https://github.com/open5gs/open5gs/issues/3157
- https://github.com/open5gs/open5gs/releases/tag/v2.7.2
- https://vuldb.com/cve/CVE-2024-14044
- https://vuldb.com/submit/867117
- https://vuldb.com/vuln/387282
- https://vuldb.com/vuln/387282/cti
Get alerted when CVE-2024-14044 or the next vulnerability affects your stack