What’s Vulnerable › Vulnerabilities
CVE-2024-1407: Paid Memberships Pro <= 2.12.10 - Cross-Site Request Forgery to Membership Modification
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-06-17
- Weakness: CWE-352
Description
The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.12.10. This is due to missing or incorrect nonce validation on multiple functions. This makes it possible for unauthenticated attackers to subscribe to, modify, or cancel membership for a user via a forged request granted they can trick a user into performing an action such as clicking on a link.
Affected products
- Paid Memberships Pro: before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: Paid Memberships Pro 3.0. Check the vendor advisory for mitigations.
References
- https://github.com/strangerstudios/paid-memberships-pro/pull/2839
- https://github.com/strangerstudios/paid-memberships-pro/pull/2893
- https://plugins.trac.wordpress.org/browser/paid-memberships-pro/tags/2.12.10/includes/functions.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3058329%40paid-memberships-pro%2Ftrunk&old=3033153%40paid-memberships-pro%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c46bcbd1-566d-4b21-84a1-f25e3df7ddc7?source=cve
- https://github.com/strangerstudios/paid-memberships-pro/pull/2839
- https://github.com/strangerstudios/paid-memberships-pro/pull/2893
- https://plugins.trac.wordpress.org/browser/paid-memberships-pro/tags/2.12.10/includes/functions.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3058329%40paid-memberships-pro%2Ftrunk&old=3033153%40paid-memberships-pro%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c46bcbd1-566d-4b21-84a1-f25e3df7ddc7?source=cve
Get alerted when CVE-2024-1407 or the next vulnerability affects your stack