What’s Vulnerable › Vulnerabilities

CVE-2024-1412: Memberpress <= 1.11.24 - Reflected Cross-Site Scripting via message and error

Description

The Memberpress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘message’ and 'error' parameters in all versions up to, and including, 1.11.26 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Note - the issue was partially patched in 1.11.25, but could still potentially be exploited under some circumstances.

Affected products

How to fix

Upgrade to a fixed version: Memberpress 1.11.27. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-1412 or the next vulnerability affects your stack