What’s Vulnerable › Vulnerabilities
CVE-2024-1449: Master Slider – Responsive Touch Slider <= 3.9.10 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Master Slider – Responsive Touch Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's ms_slide shortcode in all versions up to, and including, 3.9.10 due to insufficient input sanitization and output escaping on the 'src' user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- averta Master Slider – Responsive Touch Slider: before 3.9.10 — fixed in 3.9.10
How to fix
Upgrade to a fixed version: averta Master Slider – Responsive Touch Slider 3.9.10. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3138224/master-slider/trunk/includes/msp-shortcodes.php
- https://wordpress.org/plugins/master-slider/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/af9adb6b-f726-4b74-be5c-82fdab0ae1f2?source=cve
- https://wordpress.org/plugins/master-slider/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/af9adb6b-f726-4b74-be5c-82fdab0ae1f2?source=cve
Get alerted when CVE-2024-1449 or the next vulnerability affects your stack