What’s Vulnerable › Vulnerabilities
CVE-2024-1452: GenerateBlocks <= 1.8.2 - Sensitive Information Exposure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-863
Description
The GenerateBlocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.8.2 via Query Loop. This makes it possible for authenticated attackers, with contributor access and above, to see contents of posts and pages in draft or private status as well as those with scheduled publication dates.
Affected products
- edge22 GenerateBlocks: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: edge22 GenerateBlocks 1.8.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/generateblocks/trunk/includes/class-query-loop.php#L140
- https://plugins.trac.wordpress.org/browser/generateblocks/trunk/includes/class-query-loop.php#L70
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3041431%40generateblocks%2Ftrunk&old=2995923%40generateblocks%2Ftrunk&sfp_email=&sfph_mail=#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/62f19301-2311-4989-a5f2-9f845b72dd54?source=cve
- https://plugins.trac.wordpress.org/browser/generateblocks/trunk/includes/class-query-loop.php#L140
- https://plugins.trac.wordpress.org/browser/generateblocks/trunk/includes/class-query-loop.php#L70
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3041431%40generateblocks%2Ftrunk&old=2995923%40generateblocks%2Ftrunk&sfp_email=&sfph_mail=#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/62f19301-2311-4989-a5f2-9f845b72dd54?source=cve
Get alerted when CVE-2024-1452 or the next vulnerability affects your stack