What’s Vulnerable › Vulnerabilities
CVE-2024-1478: Maintenance Mode <= 3.0.1 - Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-284
Description
The Maintenance Mode plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.1 via the REST API. This makes it possible for unauthenticated attackers to obtain post and page content via API thus bypassing the content protection provided by the plugin.
Affected products
- helderk Maintenance Mode: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: helderk Maintenance Mode 3.0.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3044964%40hkdev-maintenance-mode&new=3044964%40hkdev-maintenance-mode&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/hkdev-maintenance-mode/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/36def628-e09e-4da0-ab14-35aefcb67f73?source=cve
- https://wordpress.org/plugins/hkdev-maintenance-mode/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/36def628-e09e-4da0-ab14-35aefcb67f73?source=cve
Get alerted when CVE-2024-1478 or the next vulnerability affects your stack