What’s Vulnerable › Vulnerabilities
CVE-2024-1479: WP Show Posts <= 1.1.4 - Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-863
Description
The WP Show Posts plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.1.4 via the wpsp_display function. This makes it possible for authenticated attackers with contributor access and above to view the contents of draft, trash, future, private and pending posts and pages.
Affected products
- edge22 WP Show Posts: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: edge22 WP Show Posts 1.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-show-posts/trunk/wp-show-posts.php#L224
- https://plugins.trac.wordpress.org/browser/wp-show-posts/trunk/wp-show-posts.php#L591
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3041416%40wp-show-posts%2Ftrunk&old=2846296%40wp-show-posts%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6788e2ee-ce61-494b-8d7f-6d1144466e58?source=cve
- https://plugins.trac.wordpress.org/browser/wp-show-posts/trunk/wp-show-posts.php#L224
- https://plugins.trac.wordpress.org/browser/wp-show-posts/trunk/wp-show-posts.php#L591
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3041416%40wp-show-posts%2Ftrunk&old=2846296%40wp-show-posts%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6788e2ee-ce61-494b-8d7f-6d1144466e58?source=cve
Get alerted when CVE-2024-1479 or the next vulnerability affects your stack