What’s Vulnerable › Vulnerabilities
CVE-2024-1482: Improper Authorization in GitHub Enterprise Server allowed unauthorized workflow execution
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-14 · updated 2026-06-17
- Weakness: CWE-863
Description
An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed an attacker to create new branches in public repositories and run arbitrary GitHub Actions workflows with permissions from the GITHUB_TOKEN. To exploit this vulnerability, an attacker would need access to the Enterprise Server. This vulnerability affected all versions of GitHub Enterprise Server after 3.8 and prior to 3.12, and was fixed in versions 3.9.10, 3.10.7, 3.11.5. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: from 3.8.0 before 3.9.10; from 3.10.0 before 3.10.7; from 3.11.0 before 3.11.5 — fixed in 3.10.7, 3.11.5, 3.9.10
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.10.7, 3.11.5, 3.9.10. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.7
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.5
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.10
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.7
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.5
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.10
Get alerted when CVE-2024-1482 or the next vulnerability affects your stack