What’s Vulnerable › Vulnerabilities

CVE-2024-1493: Uncontrolled Resource Consumption in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 9.2 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, with the processing logic for generating link in dependency files can lead to a regular expression DoS attack on the server

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.11.5, 17.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-1493 or the next vulnerability affects your stack