What’s Vulnerable › Vulnerabilities
CVE-2024-1503: Tutor LMS – eLearning and online course solution <= 2.6.1 - Cross-Site Request Forgery to Plugin Deactivation and Data Erase
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-352
Description
The Tutor LMS – eLearning and online course solution plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.1. This is due to missing or incorrect nonce validation on the erase_tutor_data() function. This makes it possible for unauthenticated attackers to deactivate the plugin and erase all data via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This requires the "Erase upon uninstallation" option to be enabled.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.6.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/tutor/trunk/classes/Admin.php#L465
- https://www.wordfence.com/threat-intel/vulnerabilities/id/050647a8-6743-46e4-b31c-0b5bd4a1007f?source=cve
- https://plugins.trac.wordpress.org/browser/tutor/trunk/classes/Admin.php#L465
- https://www.wordfence.com/threat-intel/vulnerabilities/id/050647a8-6743-46e4-b31c-0b5bd4a1007f?source=cve
Get alerted when CVE-2024-1503 or the next vulnerability affects your stack