What’s Vulnerable › Vulnerabilities
CVE-2024-1505: Academy LMS – eLearning and online course solution for WordPress <= 1.9.19 - Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-269
Description
The Academy LMS – eLearning and online course solution for WordPress plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.9.19. This is due to plugin allowing arbitrary user meta updates through the saved_user_info() function. This makes it possible for authenticated attackers, with minimal permissions such as students, to elevate their user role to that of an administrator.
Affected products
- kodezen Academy LMS – WordPress LMS Plugin for Complete eLearning Solution: before 1.9.20 — fixed in 1.9.20
How to fix
Upgrade to a fixed version: kodezen Academy LMS – WordPress LMS Plugin for Complete eLearning Solution 1.9.20. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3037880/academy#file473
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b150f90a-ccb7-4c19-a4b3-eaf9ec264ba8?source=cve
- https://plugins.trac.wordpress.org/changeset/3037880/academy#file473
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b150f90a-ccb7-4c19-a4b3-eaf9ec264ba8?source=cve
Get alerted when CVE-2024-1505 or the next vulnerability affects your stack