What’s Vulnerable › Vulnerabilities
CVE-2024-1508: Prime Slider – Addons For Elementor <= 3.13.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Mercury Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Prime Slider – Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'settings['title_tags']' attribute of the Mercury widget in all versions up to, and including, 3.13.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- bdthemes Prime Slider – Addons for Elementor: before 3.13.3 — fixed in 3.13.3
How to fix
Upgrade to a fixed version: bdthemes Prime Slider – Addons for Elementor 3.13.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3047591/bdthemes-prime-slider-lite
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7da00af0-edd1-4c39-ae33-a0dc21bd25a2?source=cve
- https://plugins.trac.wordpress.org/changeset/3047591/bdthemes-prime-slider-lite
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7da00af0-edd1-4c39-ae33-a0dc21bd25a2?source=cve
Get alerted when CVE-2024-1508 or the next vulnerability affects your stack