What’s Vulnerable › Vulnerabilities
CVE-2024-1520: OS Command Injection in parisneo/lollms-webui
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 48.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS Command Injection vulnerability exists in the '/open_code_folder' endpoint of the parisneo/lollms-webui application, due to improper validation of user-supplied input in the 'discussion_id' parameter. Attackers can exploit this vulnerability by injecting malicious OS commands, leading to unauthorized command execution on the underlying operating system. This could result in unauthorized access, data leakage, or complete system compromise.
Affected products
- ParisNeo lollms-webui: from 9.0 before 9.2 — fixed in 9.2
How to fix
Upgrade to a fixed version: ParisNeo lollms-webui 9.2. Check the vendor advisory for mitigations.
References
- https://github.com/parisneo/lollms-webui/commit/2497d1a4fe5a09f003bf7a9bc426139e9295a934
- https://huntr.com/bounties/405c2059-3fe9-4233-8eed-741ec847d181
- https://github.com/parisneo/lollms-webui/commit/2497d1a4fe5a09f003bf7a9bc426139e9295a934
- https://huntr.com/bounties/405c2059-3fe9-4233-8eed-741ec847d181
Get alerted when CVE-2024-1520 or the next vulnerability affects your stack