What’s Vulnerable › Vulnerabilities
CVE-2024-1538: File Manager <= 7.2.4 - Cross-Site Request Forgery to Local JS File Inclusion
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-352
Description
The File Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 7.2.4. This is due to missing or incorrect nonce validation on the wp_file_manager page that includes files through the 'lang' parameter. This makes it possible for unauthenticated attackers to include local JavaScript files that can be leveraged to achieve RCE via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This issue was partially patched in version 7.2.4, and fully patched in 7.2.5.
Affected products
- File Manager Pro: before 7.2.5 — fixed in 7.2.5
How to fix
Upgrade to a fixed version: File Manager Pro 7.2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3051451/wp-file-manager
- https://www.wordfence.com/threat-intel/vulnerabilities/id/57cc15a6-2cf5-481f-bb81-ada48aa74009?source=cve
- https://plugins.trac.wordpress.org/changeset/3051451/wp-file-manager
- https://www.wordfence.com/threat-intel/vulnerabilities/id/57cc15a6-2cf5-481f-bb81-ada48aa74009?source=cve
Get alerted when CVE-2024-1538 or the next vulnerability affects your stack