What’s Vulnerable › Vulnerabilities
CVE-2024-1558: Path Traversal Vulnerability in mlflow/mlflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-22
Description
A path traversal vulnerability exists in the `_create_model_version()` function within `server/handlers.py` of the mlflow/mlflow repository, due to improper validation of the `source` parameter. Attackers can exploit this vulnerability by crafting a `source` parameter that bypasses the `_validate_non_local_source_contains_relative_paths(source)` function's checks, allowing for arbitrary file read access on the server. The issue arises from the handling of unquoted URL characters and the subsequent misuse of the original `source` value for model version creation, leading to the exposure of sensitive files when interacting with the `/model-versions/get-artifact` handler.
Affected products
- mlflow/mlflow: before 2.12.1 — fixed in 2.12.1
How to fix
Upgrade to a fixed version: mlflow/mlflow 2.12.1. Check the vendor advisory for mitigations.
References
- https://huntr.com/bounties/7f4dbcc5-b6b3-43dd-b310-e2d0556a8081
- https://huntr.com/bounties/7f4dbcc5-b6b3-43dd-b310-e2d0556a8081
Get alerted when CVE-2024-1558 or the next vulnerability affects your stack