What’s Vulnerable › Vulnerabilities
CVE-2024-1572: WP ULike <= 4.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP ULike plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wp_ulike' shortcode in all versions up to, and including, 4.6.9 due to insufficient input sanitization and output escaping on the user supplied 'wrapper_class' attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- alimir WP ULike – Like & Dislike Buttons for Engagement and Feedback: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: alimir WP ULike – Like & Dislike Buttons for Engagement and Feedback 4.7.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-ulike/tags/4.6.9/includes/functions/templates.php#L70
- https://plugins.trac.wordpress.org/changeset/3052611/wp-ulike/trunk/includes/classes/class-wp-ulike-cta-template.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4deb1527-0637-44f2-b336-d0cf2a48fa52?source=cve
- https://plugins.trac.wordpress.org/browser/wp-ulike/tags/4.6.9/includes/functions/templates.php#L70
- https://plugins.trac.wordpress.org/changeset/3052611/wp-ulike/trunk/includes/classes/class-wp-ulike-cta-template.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4deb1527-0637-44f2-b336-d0cf2a48fa52?source=cve
Get alerted when CVE-2024-1572 or the next vulnerability affects your stack