What’s Vulnerable › Vulnerabilities
CVE-2024-1645: Mollie Forms <= 2.6.3 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-11 · updated 2026-06-17
- Weakness: CWE-862
Description
The Mollie Forms plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the exportRegistrations function in all versions up to, and including, 2.6.3. This makes it possible for authenticated attackers, with subscriber access or higher, to export payment data collected by this plugin.
Affected products
- ndijkstra Mollie Forms: before 2.6.4 — fixed in 2.6.4
How to fix
Upgrade to a fixed version: ndijkstra Mollie Forms 2.6.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/mollie-forms/trunk/classes/Admin.php#L904
- https://plugins.trac.wordpress.org/changeset/3046896/mollie-forms/trunk/classes/Admin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/353c244f-6d5d-47d6-988e-33da722a02f9?source=cve
- https://plugins.trac.wordpress.org/browser/mollie-forms/trunk/classes/Admin.php#L904
- https://plugins.trac.wordpress.org/changeset/3046896/mollie-forms/trunk/classes/Admin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/353c244f-6d5d-47d6-988e-33da722a02f9?source=cve
Get alerted when CVE-2024-1645 or the next vulnerability affects your stack