What’s Vulnerable › Vulnerabilities
CVE-2024-1658: Grid Shortcodes < 1.1.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Grid Shortcodes WordPress plugin before 1.1.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- WP Darko Grid Shortcodes: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: WP Darko Grid Shortcodes 1.1.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9489925e-5a47-4608-90a2-0139c5e1c43c/
- https://wpscan.com/vulnerability/9489925e-5a47-4608-90a2-0139c5e1c43c/
Get alerted when CVE-2024-1658 or the next vulnerability affects your stack