What’s Vulnerable › Vulnerabilities
CVE-2024-1660: Top Bar < 3.0.5 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Top Bar WordPress plugin before 3.0.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Top Bar: before 3.0.5 — fixed in 3.0.5
How to fix
Upgrade to a fixed version: Top Bar 3.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5bd16f84-22bf-4170-b65c-08caf67d0005/
- https://wpscan.com/vulnerability/5bd16f84-22bf-4170-b65c-08caf67d0005/
Get alerted when CVE-2024-1660 or the next vulnerability affects your stack