What’s Vulnerable › Vulnerabilities
CVE-2024-1664: Responsive Gallery Grid < 2.3.11 - Admin+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Gallery Grid WordPress plugin before 2.3.11 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Responsive Gallery Grid: before 2.3.11 — fixed in 2.3.11
How to fix
Upgrade to a fixed version: Responsive Gallery Grid 2.3.11. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fc3beca7-af38-4ab2-b05f-13b47d042b85/
- https://wpscan.com/vulnerability/fc3beca7-af38-4ab2-b05f-13b47d042b85/
Get alerted when CVE-2024-1664 or the next vulnerability affects your stack