What’s Vulnerable › Vulnerabilities
CVE-2024-1677: Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce <= 3.4.6 - Improper Authorization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-862
Description
The Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce plugin for WordPress is vulnerable to unauthorized access of data, modification of data, and loss of data due to an improper capability check on 42 separate AJAX functions in all versions up to, and including, 3.4.6. This makes it possible for authenticated attackers, with subscriber access and above, to fully control the plugin which includes the ability to modify plugin settings and profiles, and create, edit, retrieve, and delete templates and barcodes.
Affected products
- ukrsolution Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce: before 3.4.7 — fixed in 3.4.7
How to fix
Upgrade to a fixed version: ukrsolution Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce 3.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3083367
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6e15d285-aa1d-461d-bdc2-642e7ccd789b?source=cve
- https://plugins.trac.wordpress.org/browser/a4-barcode-generator/trunk/class/Request.php?rev=2870656
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6e15d285-aa1d-461d-bdc2-642e7ccd789b?source=cve
Get alerted when CVE-2024-1677 or the next vulnerability affects your stack