What’s Vulnerable › Vulnerabilities
CVE-2024-1679: Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce <= 3.4.6 - Authenticated(Subscriber+) Stored Cross-Site Scripting via Templates
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the template and javascript label fields in all versions up to, and including, 3.4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- ukrsolution Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce: before 3.4.7 — fixed in 3.4.7
How to fix
Upgrade to a fixed version: ukrsolution Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce 3.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/a4-barcode-generator/trunk/class/BarcodeTemplates/BarcodeTemplatesController.php?rev=2870656
- https://plugins.trac.wordpress.org/changeset/3083367#file16
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c2d03b83-c406-4d3f-b6be-015edcc15515?source=cve
- https://plugins.trac.wordpress.org/browser/a4-barcode-generator/trunk/class/BarcodeTemplates/BarcodeTemplatesController.php?rev=2870656
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c2d03b83-c406-4d3f-b6be-015edcc15515?source=cve
Get alerted when CVE-2024-1679 or the next vulnerability affects your stack