What’s Vulnerable › Vulnerabilities
CVE-2024-1684: Otter Blocks PRO <= 2.6.3 - Authenticated(Contributor+) Stored Cross-Site Scripting via File Field CSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the contact form file field CSS metabox in all versions up to, and including, 2.6.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- themeisle Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE: before 2.6.4 — fixed in 2.6.4
How to fix
Upgrade to a fixed version: themeisle Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE 2.6.4. Check the vendor advisory for mitigations.
References
- https://store.themeisle.com/?edd_action=view_changelog&name=Otter%20Pro
- https://www.wordfence.com/threat-intel/vulnerabilities/id/934bf839-152d-4d10-9ac8-c64cf042dc18?source=cve
- https://store.themeisle.com/?edd_action=view_changelog&name=Otter%20Pro
- https://www.wordfence.com/threat-intel/vulnerabilities/id/934bf839-152d-4d10-9ac8-c64cf042dc18?source=cve
Get alerted when CVE-2024-1684 or the next vulnerability affects your stack