What’s Vulnerable › Vulnerabilities
CVE-2024-1712: Carousel Slider < 2.2.7 - Editor+ Stored XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Carousel Slider WordPress plugin before 2.2.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Carousel Slider: before 2.2.7 — fixed in 2.2.7
How to fix
Upgrade to a fixed version: Carousel Slider 2.2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/23805a61-9fcd-4744-a60d-05c8cb43ee01/
- https://wpscan.com/vulnerability/23805a61-9fcd-4744-a60d-05c8cb43ee01/
Get alerted when CVE-2024-1712 or the next vulnerability affects your stack