What’s Vulnerable › Vulnerabilities
CVE-2024-1735
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-26 · updated 2026-06-17
- Weakness: CWE-287
Description
A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.
Affected products
- line armeria: before 1.27.2 — fixed in 1.27.2
How to fix
Upgrade to a fixed version: line armeria 1.27.2. Check the vendor advisory for mitigations.
References
- https://github.com/line/armeria/security/advisories/GHSA-4m6j-23p2-8c54
- https://github.com/line/armeria/security/advisories/GHSA-4m6j-23p2-8c54
Get alerted when CVE-2024-1735 or the next vulnerability affects your stack