What’s Vulnerable › Vulnerabilities
CVE-2024-1738: Incorrect Authorization in lunary-ai/lunary
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-863
Description
An incorrect authorization vulnerability exists in the lunary-ai/lunary repository, specifically within the evaluations.get route in the evaluations API endpoint. This vulnerability allows unauthorized users to retrieve the results of any organization's evaluation by simply knowing the evaluation ID, due to the lack of project ID verification in the SQL query. As a result, attackers can gain access to potentially private data contained within the evaluation results.
Affected products
- lunary-ai/lunary: before 1.2.4 — fixed in 1.2.4
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/a4e61122e61dc31460cfbe54d15fae389cc440ce
- https://huntr.com/bounties/f68ef361-7a5d-4272-9c2f-414baf074309
- https://github.com/lunary-ai/lunary/commit/a4e61122e61dc31460cfbe54d15fae389cc440ce
- https://huntr.com/bounties/f68ef361-7a5d-4272-9c2f-414baf074309
Get alerted when CVE-2024-1738 or the next vulnerability affects your stack