What’s Vulnerable › Vulnerabilities
CVE-2024-1741: Improper Authorization in lunary-ai/lunary
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-863
Description
lunary-ai/lunary version 1.0.1 is vulnerable to improper authorization, allowing removed members to read, create, modify, and delete prompt templates using an old authorization token. Despite being removed from an organization, these members can still perform operations on prompt templates by sending HTTP requests with their previously captured authorization token. This issue exposes organizations to unauthorized access and manipulation of sensitive template data.
Affected products
- lunary-ai/lunary: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/d8e2e73efd53ab4e92cf47bbf4b639a9f08853d2
- https://huntr.com/bounties/671bd040-1cc5-4227-8182-5904e9c5ed3b
- https://github.com/lunary-ai/lunary/commit/d8e2e73efd53ab4e92cf47bbf4b639a9f08853d2
- https://huntr.com/bounties/671bd040-1cc5-4227-8182-5904e9c5ed3b
Get alerted when CVE-2024-1741 or the next vulnerability affects your stack