What’s Vulnerable › Vulnerabilities
CVE-2024-1743: WooCommerce Customers Manager < 29.8 - Reflected XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The WooCommerce Customers Manager WordPress plugin before 29.8 does not sanitise and escape various parameters before outputting them back in pages and attributes, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- WooCommerce Customers Manager: before 29.8 — fixed in 29.8
How to fix
Upgrade to a fixed version: WooCommerce Customers Manager 29.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3cb1f707-6093-42a7-a778-2b296bdf1735/
- https://wpscan.com/vulnerability/3cb1f707-6093-42a7-a778-2b296bdf1735/
Get alerted when CVE-2024-1743 or the next vulnerability affects your stack