What’s Vulnerable › Vulnerabilities
CVE-2024-1747: WooCommerce Customers Manager < 30.2 - Subscriber+ Stored XSS
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-352
Description
The WooCommerce Customers Manager WordPress plugin before 30.2 does not have authorisation and CSRF in various AJAX actions, allowing any authenticated users, such as subscriber, to call them and update/delete/create customer metadata, also leading to Stored Cross-Site Scripting due to the lack of escaping of said metadata values.
Affected products
- WooCommerce Customers Manager: before 30.2 — fixed in 30.2
How to fix
Upgrade to a fixed version: WooCommerce Customers Manager 30.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-1747 or the next vulnerability affects your stack