What’s Vulnerable › Vulnerabilities
CVE-2024-1751: Tutor LMS – eLearning and online course solution <= 2.6.1 - Authenticated (Subscriber+) SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-89
Description
The Tutor LMS – eLearning and online course solution plugin for WordPress is vulnerable to time-based SQL Injection via the question_id parameter in all versions up to, and including, 2.6.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with subscriber/student access or higher, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.6.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/tutor/tags/2.6.1/classes/Utils.php#L4555
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3049105%40tutor&new=3049105%40tutor&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f9cee379-79f8-4a60-b1bb-ccab1e954512?source=cve
- https://plugins.trac.wordpress.org/browser/tutor/tags/2.6.1/classes/Utils.php#L4555
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3049105%40tutor&new=3049105%40tutor&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f9cee379-79f8-4a60-b1bb-ccab1e954512?source=cve
Get alerted when CVE-2024-1751 or the next vulnerability affects your stack