What’s Vulnerable › Vulnerabilities
CVE-2024-1812: Everest Forms <= 2.0.7 - Unauthenticated Server-Side Request Forgery via font_url
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-918
Description
The Everest Forms plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.0.7 via the 'font_url' parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- wpeverest Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder: before 2.0.8 — fixed in 2.0.8
How to fix
Upgrade to a fixed version: wpeverest Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder 2.0.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3049743/everest-forms
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d4561441-d147-4c02-a837-c1656e17627d?source=cve
- https://plugins.trac.wordpress.org/changeset/3049743/everest-forms
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d4561441-d147-4c02-a837-c1656e17627d?source=cve
Get alerted when CVE-2024-1812 or the next vulnerability affects your stack