What’s Vulnerable › Vulnerabilities
CVE-2024-1815: Spectra – WordPress Gutenberg Blocks <= 2.12.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Gallery Block
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Spectra – WordPress Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Image Gallery block in all versions up to, and including, 2.12.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Brainstorm Force Spectra: before 2.12.9 — fixed in 2.12.9
How to fix
Upgrade to a fixed version: Brainstorm Force Spectra 2.12.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3075043/ultimate-addons-for-gutenberg
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1cd877e6-e000-437d-ba9f-0640350277e4?source=cve
- https://plugins.trac.wordpress.org/changeset/3075043/ultimate-addons-for-gutenberg
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1cd877e6-e000-437d-ba9f-0640350277e4?source=cve
Get alerted when CVE-2024-1815 or the next vulnerability affects your stack