What’s Vulnerable › Vulnerabilities
CVE-2024-1846: Responsive Tabs < 4.0.7 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Tabs WordPress plugin before 4.0.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Responsive Tabs: before 4.0.7 — fixed in 4.0.7
How to fix
Upgrade to a fixed version: Responsive Tabs 4.0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ea2a8420-4b0e-4efb-a0c6-ceea996dae5a/
- https://wpscan.com/vulnerability/ea2a8420-4b0e-4efb-a0c6-ceea996dae5a/
Get alerted when CVE-2024-1846 or the next vulnerability affects your stack