What’s Vulnerable › Vulnerabilities
CVE-2024-1851: affiliate-toolkit – WordPress Affiliate Plugin <= 3.5.4 - Missing Authorization via atkp_create_list
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-08 · updated 2026-06-17
- Weakness: CWE-862
Description
The affiliate-toolkit – WordPress Affiliate Plugin plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the atkp_create_list() function in all versions up to, and including, 3.5.4. This makes it possible for authenticated attackers, with subscriber-level access and above, to to perform unauthorized actions such as creating product lists.
Affected products
- cservit affiliate-toolkit – Multi-Network Affiliate & Amazon Product Display: before 3.5.5 — fixed in 3.5.5
How to fix
Upgrade to a fixed version: cservit affiliate-toolkit – Multi-Network Affiliate & Amazon Product Display 3.5.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3045821/affiliate-toolkit-starter/trunk/includes/atkp_endpoints.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e9e256b0-e4e3-4f41-842c-80aa2b80af72?source=cve
- https://plugins.trac.wordpress.org/changeset/3045821/affiliate-toolkit-starter/trunk/includes/atkp_endpoints.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e9e256b0-e4e3-4f41-842c-80aa2b80af72?source=cve
Get alerted when CVE-2024-1851 or the next vulnerability affects your stack