What’s Vulnerable › Vulnerabilities
CVE-2024-1855: WPCafe <= 2.2.23 - Unauthenticated Blind Server-Side Request Forgery
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-23 · updated 2026-06-17
- Weakness: CWE-918
Description
The WPCafe – Restaurant Menu, Online Ordering for WooCommerce, Pickup / Delivery and Table Reservation plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.2.23 via the wpc_check_for_submission function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application.
Affected products
- arraytics WPCafe – Restaurant Menu, Online Food Ordering & Table Booking System: before 2.2.24 — fixed in 2.2.24
How to fix
Upgrade to a fixed version: arraytics WPCafe – Restaurant Menu, Online Food Ordering & Table Booking System 2.2.24. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-cafe/trunk/core/action/wpc-ajax-action.php#L76
- https://plugins.trac.wordpress.org/changeset/3084054/wp-cafe/trunk/core/action/wpc-ajax-action.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5f83c19e-1b75-4fea-b4de-f7f844a449c0?source=cve
- https://plugins.trac.wordpress.org/browser/wp-cafe/trunk/core/action/wpc-ajax-action.php#L76
- https://plugins.trac.wordpress.org/changeset/3084054/wp-cafe/trunk/core/action/wpc-ajax-action.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5f83c19e-1b75-4fea-b4de-f7f844a449c0?source=cve
Get alerted when CVE-2024-1855 or the next vulnerability affects your stack