What’s Vulnerable › Vulnerabilities
CVE-2024-1874: Command injection via array-ish $command parameter of proc_open()
- Severity: critical (CVSS 9.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 32.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-29 · updated 2026-06-17
- Weakness: CWE-116
Description
In PHP versions 8.1.* before 8.1.28, 8.2.* before 8.2.18, 8.3.* before 8.3.5, when using proc_open() command with array syntax, due to insufficient escaping, if the arguments of the executed command are controlled by a malicious user, the user can supply arguments that would execute arbitrary commands in Windows shell.
Affected products
- Fedoraproject Fedora: 39, 40
- PHP: from 8.1.0 before 8.1.28; from 8.2.0 before 8.2.18; from 8.3.0 before 8.3.5 — fixed in 8.1.28, 8.2.18, 8.3.5
How to fix
Upgrade to a fixed version: PHP 8.1.28, 8.2.18, 8.3.5. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/12/11
- http://www.openwall.com/lists/oss-security/2024/06/07/1
- https://github.com/php/php-src/security/advisories/GHSA-pc52-254m-w9w7
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PKGTQUOA2NTZ3RXN22CSAUJPIRUYRB4B/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W45DBOH56NQDRTOM2DN2LNA2FZIMC3PK/
- https://security.netapp.com/advisory/ntap-20240510-0009/
- http://www.openwall.com/lists/oss-security/2024/04/12/11
- http://www.openwall.com/lists/oss-security/2024/06/07/1
- https://github.com/php/php-src/security/advisories/GHSA-pc52-254m-w9w7
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KJZK3X6B7FBE32FETDSMRLJXTFTHKWSY/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PKGTQUOA2NTZ3RXN22CSAUJPIRUYRB4B/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W45DBOH56NQDRTOM2DN2LNA2FZIMC3PK/
Get alerted when CVE-2024-1874 or the next vulnerability affects your stack