What’s Vulnerable › Vulnerabilities
CVE-2024-1895: Event Monster <= 1.3.9 - Authenticated(Contributor+) PHP Object Injection via Custom Meta
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-30 · updated 2026-06-17
- Weakness: CWE-502
Description
The Event Monster – Event Management, Tickets Booking, Upcoming Event plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.3.9 via deserialization via shortcode of untrusted input from a custom meta value. This makes it possible for authenticated attackers, with contributor access and above, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- Event Monster: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Event Monster 1.4.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/event-monster/tags/1.3.3/shortcode.php
- https://plugins.trac.wordpress.org/changeset/3102670
- https://www.wordfence.com/threat-intel/vulnerabilities/id/41d7b3f1-a133-4678-b2d9-3f9951cbc005?source=cve
- https://plugins.trac.wordpress.org/browser/event-monster/tags/1.3.3/shortcode.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/41d7b3f1-a133-4678-b2d9-3f9951cbc005?source=cve
Get alerted when CVE-2024-1895 or the next vulnerability affects your stack