What’s Vulnerable › Vulnerabilities
CVE-2024-1902: Session Reuse Vulnerability in lunary-ai/lunary
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-821
Description
lunary-ai/lunary is vulnerable to a session reuse attack, allowing a removed user to change the organization name without proper authorization. The vulnerability stems from the lack of validation to check if a user is still part of an organization before allowing them to make changes. An attacker can exploit this by using an old authorization token to send a PATCH request, modifying the organization's name even after being removed from the organization. This issue is due to incorrect synchronization and affects the orgs.patch route.
Affected products
- lunary-ai/lunary: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/d8e2e73efd53ab4e92cf47bbf4b639a9f08853d2
- https://huntr.com/bounties/e536310e-abe7-4585-9cf6-21f77390a5e8
- https://github.com/lunary-ai/lunary/commit/d8e2e73efd53ab4e92cf47bbf4b639a9f08853d2
- https://huntr.com/bounties/e536310e-abe7-4585-9cf6-21f77390a5e8
Get alerted when CVE-2024-1902 or the next vulnerability affects your stack