What’s Vulnerable › Vulnerabilities
CVE-2024-1904: MasterStudy LMS <= 3.2.13 - Missing Authorization to Sensitive Information Exposure in search_posts
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-862
Description
The MasterStudy LMS plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the search_posts function in all versions up to, and including, 3.2.13. This makes it possible for authenticated attackers, with subscriber-level access and above, to expose draft post titles and excerpts.
Affected products
- MasterStudy LMS WordPress Plugin: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: MasterStudy LMS WordPress Plugin 3.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3050967/masterstudy-lms-learning-management-system
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1be686d3-16b1-4ec7-b304-848ca4d7162c?source=cve
- https://plugins.trac.wordpress.org/changeset/3050967/masterstudy-lms-learning-management-system
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1be686d3-16b1-4ec7-b304-848ca4d7162c?source=cve
Get alerted when CVE-2024-1904 or the next vulnerability affects your stack