What’s Vulnerable › Vulnerabilities
CVE-2024-1905: Smart Forms < 2.6.96 - Admin+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Smart Forms WordPress plugin before 2.6.96 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Smart Forms: before 2.6.96 — fixed in 2.6.96
How to fix
Upgrade to a fixed version: Smart Forms 2.6.96. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b9a448d2-4bc2-4933-8743-58c8768a619f/
- https://wpscan.com/vulnerability/b9a448d2-4bc2-4933-8743-58c8768a619f/
Get alerted when CVE-2024-1905 or the next vulnerability affects your stack