What’s Vulnerable › Vulnerabilities
CVE-2024-1908: Improper Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed Privilege Escalation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-269
Description
An Improper Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed an attacker to use the Enterprise Actions GitHub Connect download token to fetch private repository data. An attacker would require an account on the server instance with non-default settings for GitHub Connect. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.8.16, 3.9.11, 3.10.8, and 3.11.6. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: before 3.8.16; from 3.9.0 before 3.9.11; from 3.10.0 before 3.10.8; from 3.11.0 before 3.11.6 — fixed in 3.10.8, 3.11.6, 3.8.16, 3.9.11
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.10.8, 3.11.6, 3.8.16, 3.9.11. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes/#3.8.16
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes/#3.9.11
- https://https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.8
- https://https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.16
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes/#3.8.16
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes/#3.9.11
- https://https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.8
- https://https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.16
Get alerted when CVE-2024-1908 or the next vulnerability affects your stack