What’s Vulnerable › Vulnerabilities
CVE-2024-1909: Categorify <= 1.0.7.4 - Cross-Site Request Forgery via categorifyAjaxRenameCategory
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-352
Description
The Categorify plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.7.4. This is due to missing or incorrect nonce validation on the categorifyAjaxRenameCategory function. This makes it possible for unauthenticated attackers to rename categories via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- frenify Categorify – WordPress Media Library Category & File Manager: before 1.0.7.5 — fixed in 1.0.7.5
How to fix
Upgrade to a fixed version: frenify Categorify – WordPress Media Library Category & File Manager 1.0.7.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3034410/categorify
- https://www.wordfence.com/threat-intel/vulnerabilities/id/58b29729-e9c3-4d57-affd-6142dfa8cc6f?source=cve
- https://plugins.trac.wordpress.org/changeset/3034410/categorify
- https://www.wordfence.com/threat-intel/vulnerabilities/id/58b29729-e9c3-4d57-affd-6142dfa8cc6f?source=cve
Get alerted when CVE-2024-1909 or the next vulnerability affects your stack