What’s Vulnerable › Vulnerabilities
CVE-2024-1913
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-787
Description
An attacker who successfully exploited these vulnerabilities could cause the robot to stop, make the robot controller inaccessible, or execute arbitrary code. The vulnerability could potentially be exploited to perform unauthorized actions by an attacker. This vulnerability arises under specific condition when specially crafted message is processed by the system. Below are reported vulnerabilities in the Robot Ware versions. * IRC5- RobotWare 6 < 6.15.06 except 6.10.10, and 6.13.07 * OmniCore- RobotWare 7 < 7.14
Affected products
- ABB RobotWare: from 6.0.0 before 6.10.10; from 6.10.10 (excl.) before 6.13.07; from 6.13.07 (excl.) before 6.15.06; from 7.00 before 7.14 — fixed in 6.10.10, 6.13.07, 6.15.06, 7.14
How to fix
Upgrade to a fixed version: ABB RobotWare 6.10.10, 6.13.07, 6.15.06, 7.14. Check the vendor advisory for mitigations.
References
- https://search.abb.com/library/Download.aspx?DocumentID=SI20330&LanguageCode=en&DocumentPartId=&Action=Launch
- https://search.abb.com/library/Download.aspx?DocumentID=SI20330&LanguageCode=en&DocumentPartId=&Action=Launch
Get alerted when CVE-2024-1913 or the next vulnerability affects your stack