What’s Vulnerable › Vulnerabilities
CVE-2024-1937: Brizy – Page Builder <= 2.4.44 - Missing Authorization to Authenticated (Contributor+) Post Modification
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The Brizy – Page Builder plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'update_item' function in all versions up to, and including, 2.4.44. This makes it possible for authenticated attackers, with contributor access and above, to modify the content of arbitrary published posts, which includes the ability to insert malicious JavaScript.
Affected products
- themefusecom Brizy – Page Builder: before 2.4.45 — fixed in 2.4.45
How to fix
Upgrade to a fixed version: themefusecom Brizy – Page Builder 2.4.45. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3112878/brizy/trunk/editor/api.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bb5f73c3-f40b-45d5-9947-c1a514d230f7?source=cve
- https://plugins.trac.wordpress.org/changeset/3112878/brizy/trunk/editor/api.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bb5f73c3-f40b-45d5-9947-c1a514d230f7?source=cve
Get alerted when CVE-2024-1937 or the next vulnerability affects your stack