What’s Vulnerable › Vulnerabilities

CVE-2024-1942

Description

Mattermost versions 8.1.x before 8.1.9, 9.2.x before 9.2.5, and 9.3.0 fail to sanitize the metadata on posts containing permalinks under specific conditions, which allows an authenticated attacker to access the contents of individual posts in channels they are not a member of.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.9, 9.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-1942 or the next vulnerability affects your stack