What’s Vulnerable › Vulnerabilities
CVE-2024-1947: Improper Handling of Highly Compressed Data (Data Amplification) in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-23 · updated 2026-06-17
- Weakness: CWE-409
Description
A denial of service (DoS) condition was discovered in GitLab CE/EE affecting all versions from 13.2.4 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1. By leveraging this vulnerability an attacker could create a DoS condition by sending crafted API calls.
Affected products
- GitLab: from 13.2.4 before 16.10.6; from 16.11.0 before 16.11.3; 17.0.0 — fixed in 16.10.6, 16.11.3
How to fix
Upgrade to a fixed version: GitLab 16.10.6, 16.11.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/443559
- https://hackerone.com/reports/2380264
- https://gitlab.com/gitlab-org/gitlab/-/issues/443559
- https://hackerone.com/reports/2380264
Get alerted when CVE-2024-1947 or the next vulnerability affects your stack