What’s Vulnerable › Vulnerabilities
CVE-2024-1952
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-200
Description
Mattermost version 8.1.x before 8.1.9 fails to sanitize data associated with permalinks when a plugin updates an ephemeral post, allowing an authenticated attacker who can control the ephemeral post update to access individual posts' contents in channels they are not a member of.
Affected products
- Mattermost: from 8.1.0 before 8.1.9 — fixed in 8.1.9
How to fix
Upgrade to a fixed version: Mattermost 8.1.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-1952 or the next vulnerability affects your stack