What’s Vulnerable › Vulnerabilities

CVE-2024-1953

Description

Mattermost versions 8.1.x before 8.1.9, 9.2.x before 9.2.5, 9.3.0, and 9.4.x before 9.4.2 fail to limit the number of role names requested from the API, allowing an authenticated attacker to cause the server to run out of memory and crash by issuing an unusually large HTTP request.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.9, 9.2.5, 9.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-1953 or the next vulnerability affects your stack