What’s Vulnerable › Vulnerabilities
CVE-2024-1956: WPB Show Core < 2.7 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The wpb-show-core WordPress plugin before 2.7 does not sanitise and escape the parameters before outputting it back in the response of an unauthenticated request, leading to a Reflected Cross-Site Scripting
Affected products
- wpb-show-core: before 2.7 — fixed in 2.7
How to fix
Upgrade to a fixed version: wpb-show-core 2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d7034ac2-0098-48d2-9ba9-87e09b178f7d/
- https://wpscan.com/vulnerability/d7034ac2-0098-48d2-9ba9-87e09b178f7d/
Get alerted when CVE-2024-1956 or the next vulnerability affects your stack