What’s Vulnerable › Vulnerabilities
CVE-2024-1957: GiveWP – Donation Plugin and Fundraising Platform <= 3.6.1 -- Authenticated(Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'give_form' shortcode in all versions up to, and including, 3.6.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- stellarwp GiveWP – Donation Plugin and Fundraising Platform: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: stellarwp GiveWP – Donation Plugin and Fundraising Platform 3.7.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3068610/give/tags/3.7.0/includes/shortcodes.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/61901d83-0d05-4be8-a318-43bea086293a?source=cve
- https://plugins.trac.wordpress.org/changeset/3068610/give/tags/3.7.0/includes/shortcodes.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/61901d83-0d05-4be8-a318-43bea086293a?source=cve
Get alerted when CVE-2024-1957 or the next vulnerability affects your stack